Sign in to follow this  
castseethee

Autobolt Servicing Promotion

33 posts in this topic

Hi. Was told by Alvin about the 3 x servicing package offered by autobolt. Did anyone else take it up? 1k.

 

If im not wrong includes the usual stuff including air con filter.

Share this post


Link to post
Share on other sites
Hi. Was told by Alvin about the 3 x servicing package offered by autobolt. Did anyone else take it up? 1k.

If im not wrong includes the usual stuff including air con filter.[/quot

 

intend to. it cover for 3 yrs..

Share this post


Link to post
Share on other sites

I can verify the $1k brake pads + brake wear sensors. Anyone know if we can change the pads without changing the sensors?

Share this post


Link to post
Share on other sites

Anyone has more details for this 3 x servicing package ? What is covered and what is not etc.

Or do we need to PM autobolt directly ?

 

Thanks

Share this post


Link to post
Share on other sites

I am planning to try other workshops because Wearnes recently charged me $1000+ for brake pads and disc and another $600+ for car battery.

Wow tats alot.....I'm running aftermarket....the amt you quoted above is how much I paid for Brakes upgrade (Front calipers to 355+ 4 slotted disc rotors + Ceramic Brake pads)

Battery I'm using Varta (I think) for 340SGD

Share this post


Link to post
Share on other sites

just went down yesterday. 

went down to change rear brake pad and sensor 

total damage after 10% off S$225.00

 

 

for 3x service 3L petrol XF 
castrol engine oil with c1 - change everytime

oil filter - change everytime

air con filter change 1x i think

filter change 1x also i think

Share this post


Link to post
Share on other sites

Can PM me the contact for Autobolt? Thanks!

Share this post


Link to post
Share on other sites

yes they do diesel, i will be sending my car in for servicing tomorrow morning and will probably try out the 3x service package.

 

Update, did my service and signed 3x package for 1k.

changed my wipers too and got a discount for showing  jaguar club member decal on windscreen..

 

Overall happy with service rendered and no complaints. 

Share this post


Link to post
Share on other sites

Sweet. At least got a workshop to service diesel car. By the way where to get the club member decal?

 

Thanks.

 

Join the meet ups to get.

Share this post


Link to post
Share on other sites

Join the meet ups to get.

 

When is the next one?

 

What is included in the Autobolt servicing package? And I need a look at my air-con.. Does Autobolt also look at that?

Any bros have the same issue? Not cold when started, but gets back to normal about 5 mins of drive?

Share this post


Link to post
Share on other sites

Guys can pm me Autobolt address Tq ,Have anyone of you guy ever come across every time you refuel petrol your car got problem start your engine ? Only after refueling.

Share this post


Link to post
Share on other sites

Guys can pm me Autobolt address Tq ,Have anyone of you guy ever come across every time you refuel petrol your car got problem start your engine ? Only after refueling.

What is the year of manufacture of your XF and elaborate more on 'got problem starting the engine'? Mine is a 2015 model and I experienced intermittent start issues (have to press Start button twice) when I first got the car. Sent it in to Wearnes and they did a firmware upgrade of the Start button function (apparently, they adjusted the pressure sensor settings of the footbrake). No problems ever since.

Share this post


Link to post
Share on other sites

What is the year of manufacture of your XF and elaborate more on 'got problem starting the engine'? Mine is a 2015 model and I experienced intermittent start issues (have to press Start button twice) when I first got the car. Sent it in to Wearnes and they did a firmware upgrade of the Start button function (apparently, they adjusted the pressure sensor settings of the footbrake). No problems ever since.

mine is 2013 model , it only happen every time I refuel my car , after refuel I press on the start button I can't start the engine only tickling sound and have to press a few time to get it engine start , even when it started , the engine like going to die off like no fuel inside and I have to press on the accelerator hard to get the the engine going . Went to Autobolt for check up they say is due to petrol which I pump which is not clean be cos I travel a lot t o Malaysia , they ask me to change my fuel filter but they can't confirm that the problem also , still consider whether to change or not , maybe I will get an second opinion

Share this post


Link to post
Share on other sites

mine is 2013 model , it only happen every time I refuel my car , after refuel I press on the start button I can't start the engine only tickling sound and have to press a few time to get it engine start , even when it started , the engine like going to die off like no fuel inside and I have to press on the accelerator hard to get the the engine going . Went to Autobolt for check up they say is due to petrol which I pump which is not clean be cos I travel a lot t o Malaysia , they ask me to change my fuel filter but they can't confirm that the problem also , still consider whether to change or not , maybe I will get an second opinion

 

Assuming all engines works the same..

a more budget way is to wash the FO filter and reuse. If the issue gets better, than change the filter to a new one. It should be the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this