Jump to content
Sign in to follow this  
ginza1960

Petrol not flowing when pumping/No power from standstill

Recommended Posts

My 5.5 years XF 2.2 diesel giving me headache.

1.  Petrol pump cannot be latched when pumping petrol.  Have to regulate at ridiculous slow speed to get the tank filled.  Anyone faced this issue before?  

2.  No power when stepping on accelerator from standstill.  Have it checked outside workshop and could be turbo problem.  Gonna cost a few grand to fix outside and more than 10 grand to be fixed at Wearnes if it is indeed a turbo problem and need to change.  Acceleration normal when start using paddle shifters.  Any owners faced this before?

Just wondering how can turbo charger fails when it is only 5 over years.  Previously had the Restricted Performance lightup which was thought to be a turbo issue.  However got fixed when brought to Wearnes for a software reset.

Guess what car I am not buying when its time to change.

Thank you for your time.  Just letting out abit.

 

Share this post


Link to post
Share on other sites
47 minutes ago, ginza1960 said:

My 5.5 years XF 2.2 diesel giving me headache.

1.  Petrol pump cannot be latched when pumping petrol.  Have to regulate at ridiculous slow speed to get the tank filled.  Anyone faced this issue before?  

2.  No power when stepping on accelerator from standstill.  Have it checked outside workshop and could be turbo problem.  Gonna cost a few grand to fix outside and more than 10 grand to be fixed at Wearnes if it is indeed a turbo problem and need to change.  Acceleration normal when start using paddle shifters.  Any owners faced this before?

Just wondering how can turbo charger fails when it is only 5 over years.  Previously had the Restricted Performance lightup which was thought to be a turbo issue.  However got fixed when brought to Wearnes for a software reset.

Guess what car I am not buying when its time to change.

Thank you for your time.  Just letting out abit.

 

Hi, for number 2, you may wish to go to another thread I had started before "Jag XF 2.2D Acceleration Issue". It may be the fuel filter issue. No need a few grant to fix.

Share this post


Link to post
Share on other sites

Doesnt sound like turbo issue. More like fuel delivery system. Diesel have 2 fuel pump.  One in tank and another hihh pressure pump. Likely the latter is either choked or kaput. (That pump aint cheap and might not have stock....check with stockist or scrap yard)

Share this post


Link to post
Share on other sites

Suggest you go outside workshop with Jaguar experience to take a look. You can try Autobolt. They are at Premier @ Kaki Bukit.

Share this post


Link to post
Share on other sites

Agree, i had a turbo issue on my xf some time back. Cannot accelerate normally after 60km/h.
0 to 60km/h was okay.

Autobolt diagnosed it and replaced the turbo.

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×